Lab 1: Introduction to QGIS

NEW SKILLS:
- Add Data
- Create GRASS location & mapset
- Import Data into a GRASS mapset
- Explore geographic data

INTRODUCTION: The purpose of this lab set is to introduce students to the use of Open Source software for GIS and spatial analysis. We will focus primarily on the programs Quantum GIS (aka QGIS), GRASS, and R. In this lab we give a basic introduction to QGIS. QGIS serves as graphical user interface for many GRASS functions, so to complete these labs you will only have to download this one set of GIS software.

To download QGIS, visit the site http://www.qgis.org/ and follow the instructions. This lab set is based on QGIS version 2.2.

You will need to download the lab data sets to complete these labs. If you want your directory structure to match that of the labs, you should store the unzipped files in the following directory structure:

C:\QGISLab\BrownsPond: A data set describing a fictitious small town in New England
C:\QGISLab\California: Data from the US Census Bureau describing California
C:\QGISLab\Wheat: A data set describing yield and the factors affecting it in a wheat field.

Vector Data

1. First, confirm that you can access the shapefile data. Start QGIS we will always do this by double clicking the QGIS Desktop icon) and either click on Layer->Add a Vector Layer or click directly on the Add a Vector Layer icon:

   ![QGIS Vector Layer Icon](image)

   Click “Browse”, then navigate to the folder C:\QGISLab\California, click on counties.shp and click Open. You should see a map of California appear on the screen.

2. The next step is to import the shapefile into GRASS GIS. To import the shapefile you must first create a GRASS location and mapset. A GRASS location is a location on Earth where you
will construct some maps. A GRASS mapset is a particular set of maps within a location. On your computer, a location is just a folder, and a mapset is a subfolder within it. **IMPORTANT:** As you create GRASS locations, you should put all of them in the same folder so that you can easily find them later. You can’t make any progress if you don’t know where they are. For example, if you have created a folder C:\QGISLab as suggested above, you could create a subfolder Locations in which to put them.

- Click on Plugins in the menu bar. If GRASS is not a selection, click on Plugin manager and check the box next to GRASS.
- Click on Plugins -> GRASS -> New mapset
- In the first window (GRASS database), click on the “Browse ...” button and navigate to C:\QGISLab and click Choose. Click Next.
- In the next window, in the “Create a new location” field, type CalifGRASS. Click Next.
- In the next window, under “Coordinate reference systems of the world”, scroll to select NAD27. Click Next.
- In the next window select United States from the dropdown menu as the extent and click on Set. Click Next.
- In the next window type CalifGRASSData as the new mapset. Click Next.
- Click Finish

Next, we will import the shapefile. Click on Plugins->GRASS->Open GRASS tools. You can also use the Open GRASS Tools button on the toolbar. It looks like a crossed hammer and wrench with a clump of grass.

- Click on the Modules Tree tab
- Navigate to File management -> Import into GRASS -> Import vector into GRASS -> “v.in.ogr.qgis – Import loaded vector” and double click.
- In the “Loaded layer” file selection, select “counties.” Type countiesGR under “Name for output vector map”. Sometimes if you have a shapefile and a GRASS layer loaded in the same project, it is hard to tell which is which on the screen, and the “GR” at the end makes this easier. NOTE: You may have scroll down to see the appropriate location to type in the name.
- Click Run. After the process finishes (it should say “Successfully finished”), click Close. You can now close the GRASS Tools window.

You have created a GRASS vector layer, located in your current mapset (CalifGRASSData). Click on Plugins->GRASS->Add a GRASS Vector Layer (or click on the icon), use Browse to navigate to gisdbase C:\QGISLab, location CalifGRASS, mapset CalifGRASSData, and select countiesGR. Click “OK.”

QGIS has the capacity to work both with ESRI shapefiles and with GRASS vector data. To fully exploit QGIS, it is useful to know how to carry out operations in both, and we will often repeat operations in each format. For what it’s worth, a GRASS vector dataset, unlike a shapefile, is topologically correct. If that doesn’t mean anything to you, don’t worry about it.

**NOTE:** Labs often use layers created in earlier labs, so it will be a good idea to save the things you create in each lab.
3. Repeat the procedure in Problem 2 to import the hospitals shapefile to hospitalsGR and the intrst_highway shapefile to intrst_hwyGR. Do NOT create a new mapset each time; use the existing mapset.
   - Use Add a Vector Layer to add the shapefiles hospitals.shp and intrst_highway.shp.
   - Use “v.in.ogr.qgis” from the Modules List of the GRASS Tools to import these layers, one at a time.

4. In some cases the same icon can be used for both ESRI and GRASS data. Click on countiesGR in the Layers window. Use the Identify Features tool to find the name and population in 1990 of the 3 California counties on the Oregon border (the northern border of the state). Answers to all questions are at the end of the lab. Now click on counties in the Layers window and confirm that you get the same information.

5. We will use the Sort feature on the attribute data in the intrst_highwayGR feature to find the route number and length of the fourth shortest interstate highway in California. Open the intrst_highwayGR Attribute table, either by right clicking on the layer in the Layers window or left clicking on the layer and using this icon. Click on the DIST_MILES column heading. If this sorts from highest to lowest, click on it again and it will reverse the sort. What is its route number and distance in miles of the fourth shortest object?? Select this row in the attribute table by clicking on its row, return to the map, and zoom into it using Zoom to Selection icon. Use the Identify Features tool to find what county it is in. Now repeat the process using the ESRI shapefile intrst_highway.

**Raster Data**

6. Start QGIS or open a new project if QGIS is already running. Click on the Add a Raster Layer icon (immediately below the Add a Vector Layer icon; see problem 1 above). Navigate to C:\QGISLab\wheat and select field5y.asc. When you are asked to select a coordinate system, first, if it is expanded, click on the box to un-expand Geographic Coordinate Systems. Next, if necessary expand Projected coordinate systems and then locate (this may take a bit of scrolling) World Geodetic System 1984UTM fuseau 10. “Fuseau” is French for “zone.” Select this Coordinate Reference System. Make sure you do not select fuseau 10 Sud. “Sud” is French for “south” and is for the southern hemisphere. Click OK. The yield map of field 5 should appear. If it is a single shade of gray, do the following:
   - Right click on the layer name in the Layers window.
   - Click on Properties.
   - In the Style tab, under Contrast Enhancement, for Current select Stretch to MinMax
   - Click ok
You should see a yield map of the wheat field that looks like this (the darker areas indicate lower wheat yield).
7. Next, we will import the raster data into GRASS using a quick method.
   - Click on Plugins->GRASS
   - If Open GRASS Tools is greyed out, click on Open Mapset and open the CaliGRASSData mapset (the GRASS Tools won’t run unless there is an open mapset).
   - Click on Open GRASS Tools
   - Click on the Modules Tree tab
   - Expand “Create new GRASS location and transfer data into it.”
   - Expand “Create new GRASS location from raster data.”
   - Click on r.in.gdal.qgis.loc
   - Under Loaded layer select field5Y
   - Under Name for output raster map type Field5YGR.
   - Scroll down. Under Name of new location to create Type WheatGRASS (get the pun?)
   - Click Run. After the process finishes (it should say “Successfully finished”), click Close.
   - Click Plugins->GRASS->Add GRASS Raster Layer. Select Location WheatGRASS and Map name Field5YGR. Click OK. Click OK in the next window to select the Coordinate System you are given. You should see the same map, except now it will be surrounded by a rectangle.

You have created a GRASS location and raster layer. You did not create a mapset, so the later was put in the PERMANENT mapset. Also, this is not the open mapset
   - Click on Plugins->GRASS->Open mapset and select PERMANENT in the WheatGRASS location.

8. Now we will create a GRASS layer. We will NOT create a new mapset, but instead use the existing mapset PERMANENT. We will also not load the shapefile first.
   - Click on Plugins->GRASS->Open GRASS Tools. This time we will use the filter.
   - Click on the Modules List tab and in the Filter window type “v.in” (don’t type the quotes). Select v.in.ogr For OGR datasource name navigate to C:\QGISLab\Wheat and select field5samples.shp. For the output vector map type field5sampGR. Click Run.
   - Click View Output. WGS 84/UTM zone 10N should be in the “Recently used coordinate reference systems” window. Select it.
9. Select those points of the field sample data set with a weed rating equal to 5 (high weeds) by doing the following:
   - Open the f5samplesGR Attribute table (see Problem 5).
   - Locate the “Select features using an expression” icon by moving the cursor over the icons, and click on it.
   - Expand “Fields and Values” and double click on WEEDS
   - Single click on = icon
   - Click on the “all unique” button and double click on ‘5’.
   - Click Select.
Close the attribute table. Note that the corresponding points turn yellow. There is a prominent triangular shaped region in the field whose reduced yield seems to be due to high weeds (weeds equal 5). Find and click on the measure tool and measure the distance from the southern end of the field to this weedy area. What is it?

10. We will use the GRASS raster calculator to create a new layer of the field with yields greater than 7500 kg/ha. Start a new project (you do not need to save this project). Using Plugins->GRASS->New mapset,, create a new mapset called Lab1 in the WheatGRASS location (see Problem 2). Then do the following.
   - Use Plugins -> GRASS -> Add Raster Layer (or the Add GRASS raster layer icon) to add the F5yieldGR raster layer.
   - Select Plugins -> GRASS -> Open GRASS tools (or the GRASS tools icon) and in the Module Tree tab, expand Raster->Spatial Analysis->Map Algebra to r.mapcalculator – Simple map algebra.
   - Use the drop down “Select a layer” menu for A to select F5yieldGR
   - Scroll down to the Formula window and type A >= 7500.
   - In the Name for output rater map window and type GT7500GR.
   - Click Run. You may get a lot of error messages, but click through them. At the end, click View Output.
   - If you get a black rectangle for GT7500GR, right click on it in the Layers window and select Stretch using current extent.

The resulting layer will be almost all one color, with a few small areas having a yield of 7500 kg/ha or greater, like this.
11. We will repeat problem 9 outside of GRASS.
   - Uncheck the layers in the Layer window so that none are visible.
   - Add the layer field5y.asc.
   - From the Raster menu, select Raster calculator.
   - In the Raster calculator, double click on field5y@1 in the Raster bands window.
   - Click on the $\geq$ button in the operators and then type 7500 in the Raster calculator expression window.
   - Leave the output format as GeoTIFF and leave the Add result to project box checked.
   - In the Output Layer window, navigate to your data folder and create a new subfolder called Lab1. Select that folder and name the output GT7500 (no extension).
   - Click OK

You should see a similar output to that of Problem 9, although you may have to again set Stretch to current extent.

Click on the image, move to the high yield area, and read the coordinates at the lower right of the screen to answer this question: which of the coordinate pairs below are in the largest area with yield in this range?

1) 592,080, 4,270,457
2) 592,173, 4,270,682
3) 592,462, 4,270,151
4) 592,188, 4,270,500

**ANSWERS**

Problem 4.
Modoc (9,678), Siskiyou (43,531), Del Norte (23,460)

Problem 5
1780, 6.41, Solano

Problem 9
280m

Problem 11
1